nnCron problems

nnCron and nnCron LITE discussion

nnCron problems

Postby gkulcsar » Wed, 17 Aug 2005, 10:22

Hi,

I'm currently evaluating nnCron. Unfortunately it does not work too well... Here are the problems:
1. tm.exe would just freeze occasionally. There are some tasks that I cannot edit with it at all, and there are some cases when I start to edit a new task and it freezes after a few seconds. ??? OK, I can edit the crontab by hand...

2. Here is a task I would like to run every day at 5 AM:
#( etran_build
AsLoggedUser
LoadProfile
User: "egbokul" Domain: "EEMEA" SecPassword: "RMO0hMWqdsN=" LogonInteractive
Time: 0 5 * * * *
Action:
StartIn: "C:\cronjobs"
SWHide NormalPriority
START-APP: "c:\www\perl\bin\perl.exe c:\cronjobs\etran_build.pl"
)#

I can start it manually and it runs. However it is never triggered, and there is no information about it in the log file. Perhaps the time specifier is wrong, but its so simple I cannot even imagine what could go wrong with it. I need to access network drives in this task.
I tried it again and it worked - when I was logged on. However the point of a service is to run even if there are no users logged on the computer...

Config: Windows 2000 Prof., nothing special.

Thanks in advance.
gkulcsar
 
Posts: 2
Joined: Wed, 17 Aug 2005, 09:36

Postby Valery_Kondakoff » Sat, 20 Aug 2005, 09:36

1. Which nnCron build do you use? Are you experiencing the same problems with the latest beta?

2. I'm pretty sure this is the authorization problem. Just remove the 'User: ...' line, reload crontabs and see if this helps.
CU
VK
User avatar
Valery_Kondakoff
Site Admin
 
Posts: 769
Joined: Thu, 01 Jul 2004, 20:49
Location: Moscow, Russia

Postby gkulcsar » Tue, 23 Aug 2005, 14:46

1. I tried it with the latest release that was available on the downloads page. I'm not interested in using beta software.

2. Yes, you were right, the problematic part was the authentication part, when I removed it my script ran just fine - apart from the fact that it was not able to do anything useful as it was not able to access network drives. I even tried it with a simple password instead of the secpassword part, but it did not help.

Since I hadn't had even the slightest hint about what had been going wrong I uninstalled nnCron. I figured out that the scheduler in Windows is sufficient for my needs - and it handles user authorization correctly.
gkulcsar
 
Posts: 2
Joined: Wed, 17 Aug 2005, 09:36


Return to nnCron forum (English)

Who is online

Users browsing this forum: No registered users and 1 guest

cron