Console disconnects unexpectedly? when issuing certain cmd

nnCron and nnCron LITE discussion

Console disconnects unexpectedly? when issuing certain cmd

Postby LuckMan212 » Sat, 17 Sep 2005, 11:25

hello,

using nnCron v 1.91 RC1 Build 1062 15.09.2005
when typing the following into the Console,
Code: Select all
2005 9 17 1 DAY+ TYPE

my console disconnects the session.
see screenshot below
Image

have I typed invalid command? why does this happen? :roll:
LuckMan212
 
Posts: 133
Joined: Mon, 04 Jul 2005, 11:19

Postby Nicholas_Nemtsev » Sat, 17 Sep 2005, 13:36

DAY+ returns 3 number ( y m d ).
Code: Select all
2005 9 17 1 DAY+ . . .
Nicholas Nemtsev
User avatar
Nicholas_Nemtsev
Site Admin
 
Posts: 857
Joined: Thu, 01 Jul 2004, 22:25
Location: Псков

Postby LuckMan212 » Sat, 17 Sep 2005, 18:36

ok but why does this close the console connection?
LuckMan212
 
Posts: 133
Joined: Mon, 04 Jul 2005, 11:19

Postby Valery_Kondakoff » Sat, 17 Sep 2005, 20:51

Just because wrong usage of TYPE can destroy the stack. From the docs: "Forth is a very powerful, and hence, somewhat dangerous tool. Careless use of Forth may crash nnCron or even destabilize the entire system. "
CU
VK
User avatar
Valery_Kondakoff
Site Admin
 
Posts: 769
Joined: Thu, 01 Jul 2004, 20:49
Location: Moscow, Russia

Postby LuckMan212 » Sat, 17 Sep 2005, 20:54

OK thank you Valery!
LuckMan212
 
Posts: 133
Joined: Mon, 04 Jul 2005, 11:19


Return to nnCron forum (English)

Who is online

Users browsing this forum: No registered users and 2 guests