Standard application not used

nnCron and nnCron LITE discussion

Standard application not used

Postby buehrenm » Sat, 29 Nov 2008, 01:45

Hi,

when I type "test.pl" on the windows command line, the Perl Script test.pl is run by the Perl command line interpreter. However, since some days, when nnCron LITE starts test.pl, the script is loaded in the windows editor instead. How can that happen? nnCron LITE worked perfectly for more than a year...

Markus
buehrenm
 
Posts: 4
Joined: Sat, 29 Nov 2008, 01:41

Re: Standard application not used

Postby SeMa » Wed, 03 Dec 2008, 17:49

I don't think that is nncron's "guilty" :?
Look associations .PL in types of files (or in the registry).
Компьютер ─ устройство, разработанное для ускорения и автоматизации человеческих ошибок
User avatar
SeMa
 
Posts: 637
Joined: Fri, 15 Apr 2005, 12:49
Location: Украина

Re: Standard application not used

Postby buehrenm » Wed, 03 Dec 2008, 19:04

Thanks for your answer. When I start a Perl script on the MS-DOS command line, e.g. "test.pl", the Perl script is executed.So the settings are correct, at least for my user. I have also set the service to run a my user, but nothing changed.

Markus
buehrenm
 
Posts: 4
Joined: Sat, 29 Nov 2008, 01:41

Re: Standard application not used

Postby SeMa » Fri, 05 Dec 2008, 17:07

AsLoggedUser ?
Компьютер ─ устройство, разработанное для ускорения и автоматизации человеческих ошибок
User avatar
SeMa
 
Posts: 637
Joined: Fri, 15 Apr 2005, 12:49
Location: Украина

Re: Standard application not used

Postby buehrenm » Fri, 05 Dec 2008, 17:24

AsLoggedUser ON
buehrenm
 
Posts: 4
Joined: Sat, 29 Nov 2008, 01:41

Re: Standard application not used

Postby Valery_Kondakoff » Thu, 11 Dec 2008, 18:40

I'm not sure what is wrong here, but I think the easiest way to fix this problem is to set the perl interpreter explicitly (using the full path to perl.exe). Have you tried this?
CU
VK
User avatar
Valery_Kondakoff
Site Admin
 
Posts: 769
Joined: Thu, 01 Jul 2004, 20:49
Location: Moscow, Russia

Re: Standard application not used

Postby buehrenm » Mon, 15 Dec 2008, 22:40

Setting the Perl Interpreter directly helped, thanks. However, I think my problems had to do with the Remote Desktop Connection I used. I start cron.exe no longer as service now and things seem to work now.

Thanks!

Markus
buehrenm
 
Posts: 4
Joined: Sat, 29 Nov 2008, 01:41


Return to nnCron forum (English)

Who is online

Users browsing this forum: No registered users and 3 guests