Missed tasks running multiple times

nnCron and nnCron LITE discussion

Missed tasks running multiple times

Postby jpb2001 » Wed, 15 Nov 2006, 17:02

I have an issue where missed tasks are being triggered more than once. This only seems to happen when my computer has not been started for a few days. The following is from the nncron log:

13:43:26 532 TASK [missed]: FTP_backup
13:43:26 532 Start: E:\nnCron scripts\FTP_backup.bat
13:43:26 1584 TASK [missed]: FTP_backup
13:43:26 1584 Start: E:\nnCron scripts\FTP_backup.bat
13:43:27 1056 TASK [missed]: FTP_backup
13:43:27 1056 Start: E:\nnCron scripts\FTP_backup.bat

What do the values 532, 1584, 1056 represent?

Is there a way to stop multiple instances of the same task from being started?

Thanks for any help,
JB
jpb2001
 
Posts: 4
Joined: Mon, 05 Jun 2006, 22:58

Postby Valery_Kondakoff » Wed, 15 Nov 2006, 18:39

This value represents the process thread number.
Try to add the 'SingleInstance' task option to prevent multiple instances of the same task from being started.

HTH!
CU
VK
User avatar
Valery_Kondakoff
Site Admin
 
Posts: 769
Joined: Thu, 01 Jul 2004, 20:49
Location: Moscow, Russia

Postby jpb2001 » Sat, 18 Nov 2006, 14:41

Valery,

That worked perfectly, thanks for your help.

JB
jpb2001
 
Posts: 4
Joined: Mon, 05 Jun 2006, 22:58

Postby mihai » Fri, 22 Dec 2006, 10:12

I have the same problem but i'm using the LITE version.
Can the LITE vers. support the 'SingleInstance' task option and where I have to putt it?

thx
mihai
 
Posts: 6
Joined: Fri, 22 Dec 2006, 10:02

Postby Valery_Kondakoff » Fri, 22 Dec 2006, 10:51

no. this is nnCron (not LITE) extended syntax.
CU
VK
User avatar
Valery_Kondakoff
Site Admin
 
Posts: 769
Joined: Thu, 01 Jul 2004, 20:49
Location: Moscow, Russia

Postby mihai » Fri, 22 Dec 2006, 11:01

thx for the quick reply!
is there anyway to solve this in the LITE Vers?
mihai
 
Posts: 6
Joined: Fri, 22 Dec 2006, 10:02

Postby Valery_Kondakoff » Fri, 22 Dec 2006, 17:07

let's investigate this. just show us the entry in your cron.tab and the related lines in cron.log.
CU
VK
User avatar
Valery_Kondakoff
Site Admin
 
Posts: 769
Joined: Thu, 01 Jul 2004, 20:49
Location: Moscow, Russia

Postby mihai » Sat, 23 Dec 2006, 11:55

right now i'm on Christmas break and i will show u the files wednesday when i'll be back at the office.
on my home computer it works perfectly and on my small lan (10 computers) i have this issue with 2 computers.

thx again
mihai
 
Posts: 6
Joined: Fri, 22 Dec 2006, 10:02

Postby mihai » Wed, 27 Dec 2006, 11:07

Right now my cron.tab look like this (I removed the '@'):

#CRONTAB FILE
# Classic crontab format:
# Minutes Hours Days Months WeekDays Command

#*/15 8-16 * * 1-5 checkmail.exe
40 12 * * 5 d:\backup.bat

My problem is when I use '@' the missed tasks are being triggered more than once. In the following log the task supose to run at 13:12 and 13:24 (I was logout at that time):

13:03:13 4088 Start nnCron
13:03:13 4088 Load cron.tab
13:08:31 4088 Load cron.tab
13:10:09 1444 Start nnCron
13:10:09 1444 Load cron.tab
13:12:33 1556 Start [missed]: d:\backup.bat
13:12:33 336 Start [missed]: d:\backup.bat
13:12:34 592 Start [missed]: d:\backup.bat
13:12:34 336 Start result: 0
13:12:34 592 Start result: 0
13:12:34 1556 Start result: 0
13:16:30 1444 Load cron.tab
13:17:14 1440 Service stopped.
13:18:26 1436 Start nnCron
13:18:26 1436 Load cron.tab
13:25:37 304 Start [missed]: d:\backup.bat
13:25:38 880 Start [missed]: d:\backup.bat
13:25:38 1128 Start [missed]: d:\backup.bat
13:25:38 316 Start [missed]: d:\backup.bat
13:25:38 1140 Start [missed]: d:\backup.bat
13:25:38 976 Start [missed]: d:\backup.bat
13:25:38 316 Start result: 0
13:25:38 1140 Start result: 0
13:25:38 1128 Start result: 0
13:25:38 880 Start result: 0
13:25:38 304 Start result: 0
13:25:38 976 Start result: 0
13:31:31 1436 Load cron.tab
15:27:30 1436 Load cron.tab
mihai
 
Posts: 6
Joined: Fri, 22 Dec 2006, 10:02

Postby Valery_Kondakoff » Wed, 27 Dec 2006, 13:03

Which nnCron LITE build are you using?
CU
VK
User avatar
Valery_Kondakoff
Site Admin
 
Posts: 769
Joined: Thu, 01 Jul 2004, 20:49
Location: Moscow, Russia

Postby mihai » Wed, 27 Dec 2006, 13:24

it's the latest nnCron LITE release:
nnCron LITE. v 1.17 Build 119 09.06.2005
mihai
 
Posts: 6
Joined: Fri, 22 Dec 2006, 10:02

Postby Valery_Kondakoff » Wed, 27 Dec 2006, 14:09

trying to reproduce the problem. you said the issue is reproduceable on 2 machines. are there some OS or cron.ini differences comparing to other 10?
CU
VK
User avatar
Valery_Kondakoff
Site Admin
 
Posts: 769
Joined: Thu, 01 Jul 2004, 20:49
Location: Moscow, Russia

Postby Nicholas_Nemtsev » Wed, 27 Dec 2006, 17:47

Please, also show your etc\taskinfo.txt file.
Nicholas Nemtsev
User avatar
Nicholas_Nemtsev
Site Admin
 
Posts: 857
Joined: Thu, 01 Jul 2004, 22:25
Location: Псков

Postby mihai » Thu, 28 Dec 2006, 11:33

all the machines are win XP SP2 and all the cron.ini files are left default.
my etc\taskinfo.txt for the above cron.log:
"d:\backup.bat","27E2D067","21.12.2006/13:31:31","","22.12.2006/12:40:01","1","1"

thx for all your help
mihai
 
Posts: 6
Joined: Fri, 22 Dec 2006, 10:02


Return to nnCron forum (English)

Who is online

Users browsing this forum: No registered users and 2 guests

cron